Supersonic Flow Over a Wedge

Ahmed M Nagib Elmekawy, PhD, P.E.

Problem Specification

A uniform supersonic stream encounters a wedge with a half-angle of 15 degrees as shown in the figure below.

\[ M = 3 \]

The stream is at the following conditions:

- Mach Number \( M_1 = 3 \)
- Static Pressure \( p_1 = 1 \text{ atm} \)
- Static Temperature \( T_1 = 300 \text{ k} \)

Using FLUENT, calculate the Mach Number, static and total pressure behind the oblique shock that will be formed. Also, calculate the shock angle, pressure coefficient along the wedge and drag coefficient. Compare the FLUENT results with the corresponding analytical results.
Pre-Analysis & Start-Up

Pre-Analysis

In the hand calculations, we will be applying the conservation of energy, mass and momentum equations for a 1D inviscid compressible flow. This differs from the way that FLUENT solves the problem as FLUENT instead uses the 2D inviscid compressible flow equations.

The equations can be written as:

\[
\frac{\partial e}{\partial t} + \mathbf{u} \cdot \nabla e + \frac{p}{\rho} \nabla \cdot \mathbf{u} = 0
\]

\[
\frac{\partial \rho}{\partial t} + \mathbf{u} \cdot \nabla \rho + \rho \nabla \cdot \mathbf{u} = 0
\]

\[
\frac{\partial \mathbf{u}}{\partial t} + \mathbf{u} \cdot \nabla \mathbf{u} = -\frac{\nabla p}{\rho}
\]

Hand Calculations

Flow with \( M = 3 \) comes straight on in the x-direction towards the wedge. We know the wedge angle theta from our geometry of the wedge to be 15 degrees. See the figure below:
Step 1: We then look at the Theta-Beta-M chart:

we can find what the shock angle is corresponding to our conditions. The line $M = 3$ with wedge angle theta at 15 degrees corresponds to a shock angle beta of about 32 degrees.

Step 2: We calculate the value of the free stream Mach Number normal to the shock so we can use normal shock relations to relate quantities upstream and downstream of the shock.

$$M_{1N} = M_1 \sin(\beta)$$

Step 3: Now we can relate the normal Mach numbers to each other through the normal shock relations
We expect that the flow downstream of the shock will still be supersonic as the flow experiences only a weak oblique shock, evident from looking at the theta-beta-M chart. This also becomes clear in the hand calculations.

Alternate Procedure:
To calculate the expected results behind the shock, you can also use an oblique shock wave calculator (from Nasa). At Mach 3 and an angle of 15 degrees, we find the following:

\[
M_2 = 2.254
\]

\[
\text{Shock Angle} = 32.221^0
\]

\[
p_2 = 2.82 \text{ atmospheres}
\]

\[
T_2 = 416.4 \text{ k}
\]

Open ANSYS Workbench
We are ready to do a simulation in ANSYS Workbench! Open ANSYS Workbench by going to Start > ANSYS > Workbench. This will open the startup screen seen as seen below.
Setup Project

To begin, we need to tell ANSYS what kind of simulation we are doing. If you look to the left of the start up window, you will see the Toolbox Window. Take a look through the different selections. We will be using FLUENT to complete the simulation. Load the Fluid Flow (FLUENT) box by dragging and dropping it into the Project Schematic.

Right click the top box of the project schematic

and go to Rename, and name the project “Supersonic Flow Over a Wedge”. You are ready to create the geometry for the simulation.
Step 1: Geometry

Watch the tutorial video.

First, we need to specify that the geometry is 2-dimensional. Right click the Geometry box and select Properties. This will open the Properties of Schematic A2: Geometry Window. Under Advance Geometry Options, Change Analysis Type from 3D to 2D.
After the analysis type has been set, we are ready to launch Design Modeler, the geometry engine in ANSYS. Open Design Modeler by Right clicking the geometry box and Select New Design Modeler Geometry

Auto Constraints is not turned on by default. Turn on Auto Constraints by following these instructions:

1. Before creating a sketch, click on the "sketching" tab.

2. Next, click on Contraints and keep scrolling untill Auto Contraints appear.
3. Finally, click on Auto Contraints and check the boxes next to Global and Cursor.

Sketching

We want to sketch on the XY plane. To look at the XY plane, click the positive Z-Axis on the compass in the Graphics window.

To begin sketching, click on the Sketching tab in the Tree Outline window. To draw our domain, we will use the Rectangle tool. Click on the Rectangle icon in the Sketching Toolboxes window. In the graphics window, draw the rectangle by first clicking on the origin (make sure the P icon is showing, meaning you are in fact selecting the point), then select a point in the 1st quadrant.
Now, we need to draw the wedge outline in the geometry. We will use the line tool to create the wedge. Select the line tool in the Sketching Toolboxes window. Click on the points shown in the below figure. Make sure the "C" is showing.

Now, we need to remove the extraneous lines that we created. In the Sketching Toolboxes window, click the Modify tab, and select Trim. Next, trim the lines indicated by the figure below.
The final sketch should look like the image below

The final sketch should look like the image below

**Dimensions**

Next, we need to add the dimensions for the geometry. In the *Sketching Toolboxes* window, select the **Dimensions** tab. Next, select the general dimensioning tool **General**. To create a dimension, you first select a line. This will create a dimension for that line. Next, you will need to place the dimension next to the line. See the image below for guidance.
Next, create dimensions for the following 4 lines:

![Diagram of lines with dimensions](image)

In order to add magnitudes to the dimensions, look to the *Details* window. You will see 4 dimensions that have been specified. Click on a dimension magnitude, and notice that the corresponding dimension will be highlighted in the graphics window. Use the following diagram to add the dimensions to the geometry.

![Diagram with dimensions added](image)

When the dimensions have been correctly applied, the geometry should look like this:

![Geometry with dimensions added](image)
Create Surface

Next, we need to create a surface from the sketch. In the menu tool bar, select **Concept > Surface from Sketches**. In the graphics window, select any line of the geometry.

Next, in the details window, select **Base Objects > Apply**. Finally, press **Generate**. The geometry should now look like the figure below.

![Surface Creation Diagram]

Create a projection

Now, we want to project the center vertical line onto the surface body we just created. This will help us with our mesh. In the menu bar, select **New Sketch** icon to create a new sketch.

![Sketching Tab]

This will create a new sketch. In the **Outline** window, return to the **Sketching** tab. Again, select the **Line** tool. Draw a line from the vertex of the wedge to the top of the geometry. Make sure that when you click a vertex, a "P" appears (meaning point, constraining the line to the vertex), a "V" appears on the line (meaning vertical, putting a vertical constraint on the line), and a "C" appears when you click on the top line (constraining the newly created line to the top line). Right before you make your second click to define the line, make sure it looks like this:

![Projection Diagram]
The line will turn dark blue if you have done this correctly (meaning the line is fully constrained) Now, we need to create a line body from this sketch. In the menu bar, go to **Concepts > Lines from Sketches**. In the graphics window, select the line you just drew. In the **Outline** window, select **Base Objects > Apply**. Finally, press **Generate**.

Finally, we are ready to project the line on the surface. In the menu bar, go to **Tools > Projection**. First, you will need to select an edge. Select the middle vertical line we just created. In the **details** window, select **Edges > Apply**.

Next, we need to select the surface body for the projection. In the **Details** window, select **Target**, then select any point on the surface body.

In **Details** window, select **Target > Apply**. Finally, press **Generate**. The line should now be projected on the surface. Now that we have the surface and the projection, we no longer need the line body we first created. In the **Tree Outline** window, Expand **2 Parts, 2 Bodies**. Right click **Line Body** and select **Suppress Body**.
Change type to "Fluid"

Under "Tree Outline", select "Surface Body". Then set the type "Fluid/Solid" to Fluid.

Save Project

Save the project using File > Save. Call the project wedge. This will create two entities: a file called wedge.wbpj and a folder called wedge_files. You will need both entities to resume the project. After the session, you can save these on a flash drive.

Close Design Modeler.

Step 3 Mesh

Watch the tutorial video.

Launch the Mesher

Now that we have completed creating the geometry of the domain, we are ready to mesh it. Return to the Project Schematic Window. In the Project Schematic window, double click the Mesh box to launch the mesher.
**Mapped Face Meshing**

First we will apply a mapped face meshing; this will give us a regular mesh. First, in the *Outline* window, click to show the Mesh menu in the menu bar. In the Meshing Menu, select **Mesh Control > Face Meshing**. In the *Graphics* window, hold down CRTL, and select *both* domain faces to select it, then in the *Details* window, click **Geometry > Apply**.

**Body Sizing**

Next, we will create a body sizing for the elements that will make up the domain. In the Mesh Menu, select **Mesh Control > Sizing**. Next, select the body selection filter in the menu bar. Next, select the surface in the graphics window. In the *Details* window, select **Geometry > Apply**. Now, we want to change the element size. In the *Details Window*, select **Element Size > Default** and change the value to *0.05 m*.

**Generate the Mesh**

Now, we are ready to generate the mesh. Generate the mesh by clicking in the menu bar or by going to **Mesh > Generate Mesh**. The final mesh should resemble the one in the figure below.
Named Selections

Now, we need to create named selections to use when we set boundary conditions. To create a named selection, first ensure that the edge selection filter is selected. Next, left click on the desired edge you wish to name (multiple edges can be selected while holding down CTRL), then right click on the edge and select *Create Named Selection*.

Once you select *Create Named Selection*, a dialogue box will appear where you will enter the desired name of the boundary. Use the diagram below to name all of the boundaries of the geometry.
There are 4 edges that make up the farfield, and they can all be named at once by holding down CTRL, left clicking all the edges while holding down CTRL, then right clicking and selecting "Create Named Selection”

Once the selections are all named and the mesh is created, you may save the project and close the mesher.

**Step 4: Set Up Problem in FLUENT**

**Update the Project and Open FLUENT**

Before we open FLUENT, we need to update the project so we can import the mesh into FLUENT. To do this, click Update Project . When the project updates, double click Setup to open FLUENT.

**Initial Settings**

*Double Click* Setup in the **Workbench Project Page**.

When the **FLUENT Launcher** appears change options to "Double Precision", and then click **OK** as shown below. The Double Precision option is used to select the double-precision solver. In the double-precision solver, each floating point number is represented using 64 bits in contrast to the single-precision solver which uses 32 bits. The extra bits increase not only the precision, but also the range of magnitudes that can be represented. The downside of using double precision is that it requires more memory.
Problem Setup - General

Now, FLUENT should open. We will begin setting up some options for the solver. In the left hand window (in what I will call the Outline window), under Problem Setup, select General. The only option we need to change here is the type of solver. In the Solver window, select Density-Based.

Models

In the outline window, click Models. We will need to utilize the energy equation in order to solve this simulation. Under Models highlight Energy-Off and click Edit. Now, the Energy window will launch. Check the box next to Energy Equation and hit OK. Doing this turns on the energy equation.
We also need to change the type of viscosity model. Select **Viscous - Laminar** and click **Edit....** Choose the **Inviscid** option and press **OK**.

**Materials**

In the **Outline** window, highlight **Materials**. In the **Materials** window, highlight **Fluid**, and click **Create/Edit...**. This will launch the Create/Edit Materials window; here we can specify the properties of the fluid. Set the **Density** to **Ideal Gas**, the default values for $C_p$ (1006.43), and the Molecular Weight (28.966) are used. When you have updated these fields, press **Change/Create**.
Boundary Conditions

In the Outline window, select **Boundary Conditions**. We will now specify each boundary condition for the simulation.

**Farfield**

In the **Boundary Conditions** window, select **farfield**. Use the drop-down menu to change the Type to **pressure-far-field**. You will be asked to confirm the change, and do so by pressing **OK**. Next, a dialogue box will open with some parameters we need to specify. Change the **Gauge Pressure (Pascal)** to **101325**, and **Mach Number** to **3**.

Also, select the **Thermal** tab, and ensure that the temperature correctly defaulted to **300 K**. When you are finished, press **OK**.
Wedge
In the *Boundary Conditions* window, select *wedge*. Use the drop-down menu to change the *Type* to *wall*.

Symmetry
In the *Boundary Conditions* window, select *symmetry*. Use the drop-down menu to change the *Type* to *symmetry*.

Operating Conditions
In the *Boundary Conditions* window, select the *Operating Conditions* button. Change the *Gauge Pressure* to 0. Then press *OK*

It is important to check the operating conditions. When setting the density in materials to ideal gas, FLUENT calculates the density using the absolute pressure. However, the pressure we specify is the gauge pressure, not the absolute pressure. FLUENT will use the absolute pressure to compute the density therefore if we do not set the operating pressure to 0 our density will be incorrect for the flow field.

Reference Values
In the *Outline* window, select *Reference Values*. Change the *Compute From* parameter to *farfield*. Check that the values are accurate. The reference values are used when calculating the non-dimensional results such as the drag coefficient.
Step 5: Numerical Solution

Watch the tutorial video.

Solution Methods

In the Outline window, select Solution Methods to open the Solution Methods window. Under Spatial Discretization, ensure that the option under Flow Second Order Upwind is selected.

Solution Controls

In the Outline window, select Solution Controls to open the Solution Controls window. Ensure that the Courant Number is set to 5.0.

The Courant number can be considered a non dimensionalized time step. The density-based solver obtains the steady-state solution by starting with the initial guess and marching in pseudo-time until convergence is obtained. The Courant number controls the time step the solver uses. The larger it is, the faster the solution will converge but it will not be very stable and can diverge. The smaller it is, the slower it is to reach convergence but the solution is much more stable.
Monitors

In the Outline window, click Monitors to open the Monitors window. In the Monitors window, select Residuals - Print,Plot and press Edit.... This will open the Residual Monitors window. We want to change the convergence criteria for our solution. Under Equation and to the right of Continuity, change the Absolute Criteria to 1e-6. Repeat for x-velocity, y-velocity, and energy, then press OK.

Solution Initialization

In the Outline window, select Solution Initialization. We need to make an "Initial Guess" to the solution so FLUENT can iterate to find the final solution. In the Solution Initialization window, select Standard Initialization then under Compute from, select farfield from the drop down box. Check to see that the values that generate match our inputted values, then press Initialize

Run Calculation

In the Outline window, select Run Calculation. Change the Number of Iterations to 4000. Double click Calculate to run the calculation. It should a few minutes to solve. After the calculation is complete, save the project. Do not close FLUENT.
Step 6: Numerical Results

Watch the tutorial video.

Mach Number Contours

The following video shows how to make a plot of the Mach number contours using CFD Post.

To properly send the additional quantities to CFD post, you need to do the following steps in the right order. First initialize your solution, then select the additional quantities as shown in the above video and finally, run the calculation.

Summary of the above video:

1. Some calculated parameters are not by default carried over into CFD-post. We are interested in such quantities (i.e. Mach Number). To manually transfer a customized selection of quantities
   a. Select File > Data File Quantities
   b. Under Additional Quantities, Select Static Pressure, Total Pressure, Mach Number, and Total Temperature
2. Post-processing will be done in CFD-post > Double Click Results in Workbench
3. We are interested in viewing contours of Mach Number in CFD-post
   a. Select Insert > Contour > Name > Mach No.
   b. Under Details of Mach No, select Locations > symmetry 1.
   c. Variable > Mach Number > No Contours = 101

4. Turn on the mesh in the graphics pane
   a. Check the box next to symmetry 1 in the Outline tree > Click Render > Show Mesh Lines.
5. Turn off the mesh by deselecting symmetry 1 in the outline tree
6. Save a copy of the figure in the graphics pane
   a. Select the camera icon in the toolbar.

Pressure Contours

Summary of video:

1. Turn off the Mach Number contours in the graphics window
   a. Uncheck the box next to Mach no in the Outline tree.
2. We are interested in viewing contours of pressure in CFD-post
   a. Select Insert > Contour
   b. Name > Pressure Contours
   c. Under Details of Pressure contours, select Locations > symmetry 1. Variable > Pressure.
3. To increase the number of contours to 101
   a. Under Details of Pressure contours, scroll down to # of Contours. Type “101”.
**Velocity Vectors**

Summary of the video:

1. We are interested in viewing velocity vectors in CFD-post.
   a. Select Insert > Vector
   b. Type “Velocity vectors” under Name in the Insert Vector dialogue box that appears.
   c. Under Details of Velocity vectors, select Locations > symmetry 1.
2. To make the velocity vectors more visible, turn off the pressure contours
   a. Uncheck the box next to Pressure contours in the Outline tree.

---

**Plot Mach Number Variation Along \( y=0.4 \text{ m} \)**

First, we'll create a line at \( y=0.4 \text{m} \). Then, we'll plot the Mach number variation along this line using the "Chart" facility in CFD Post. These steps are shown in the video.

Summary of the video:

1. Insert line \( y = 0.4 \text{ m} \) in CFD-post.
   a. Select Location > Line > Name Line 1
   b. Under Details of Velocity vectors, type Point 1 coordinates \((0,0.4,0)\) and Point 2 coordinates \((1.5,0.4,0)\).
2. Plot Mach Number along the newly created line \( y = 0.4 \text{ m} \)
   a. Select Insert > Chart
b. Type “Mach no along Line 1” under Name

c. Under Details of Mach no along Line 1, select the Data Series Tab. Select Location > Line 1.
   i. select the X Axis tab. Select Variable > X.
   ii. select the Y Axis tab. Select Variable > Mach Number.

3. To increase the number of samples along line y = 0.4 m to 100.
   a. Double click on Line 1 in the Outline tree.
   b. Under Details of Line 1, type “100” in Samples.

---

**Step 7: Verification & Validation**

**Verification**

**Adapt the Mesh**

In order to test our simulation for convergence, we will refine the mesh. Refining the mesh will allow us to make sure that the results we are calculating are independent of the mesh. However, instead of refining the mesh everywhere (which would be wasteful, as most of the area of the domain far away from the shock has constant values), we will use our results to refine our mesh. Specifically, we are going to use the gradient of the pressure to determine where to refine the mesh.
Summary of the Video:

1. Display Current Mesh:
   a. Mesh>Setup>Display

2. In the Menu
   a. Adapt>Gradient
      i. uncheck Coarsen
      ii. select Gradient in Method Box
      iii. Gradients of > Pressure > Static Pressure
      iv. Compute

3. View Contours
   a. Contours > Contours of Adaption > Existing Value
b. Compute 
c. Display 

4. Under Contours 
   a. Uncheck Auto Range  
   b. Change Min to 10000 
   c. Display
5. Under Refine Threshold enter 10000
   a. Press Mark
   b. Press Adapt
6. Display the New Mesh

Notice that the area surrounding the shock was refined. Now, re-initialize the solution, (Solution Initialization > Compute from Farfield > Initialize), and rerun the solution (you will also need to increase the number of iterations – I recommend 150).

Now, once again, plot the contours of the Mach number. Below is a comparison of the Mach number results from the original mesh and the refined mesh.
The most striking difference between the two results is the thickness of the shock. Notice that for the refined mesh, the shock is less thick than for the original mesh. This shows that the refined mesh is converging towards the real case.

Comparison to Analytical Solution

In order to verify our simulation, we need to compare our results to either an analytical solution or an experiment. Below is a table comparing the values from the simulation with the calculations from the pre-analysis.

<table>
<thead>
<tr>
<th></th>
<th>Mach Number</th>
<th>Static Pressure (atm)</th>
<th>Shock Angle (degrees)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Theory Value</td>
<td>2.254</td>
<td>2.824</td>
<td>32.22</td>
</tr>
<tr>
<td>FLUENT Solution</td>
<td>2.243</td>
<td>2.803</td>
<td>34.99</td>
</tr>
<tr>
<td>Percent Difference</td>
<td>0.8%</td>
<td>0.7%</td>
<td>8.2%</td>
</tr>
</tbody>
</table>
As we can see from the table, we are getting fairly good matching between the computation and analytical approaches. From this we can build our trust in our simulation.

**Save Project**

Save the project using *File > Save*.

Next, you can select *File > Archive* and save the project as one file called `wege.wbpz`. When prompted, select the option to save *Result/Solution* also. You will then need to save only this file. This is also convenient to e-mail the project. Double-clicking on the `wege.wbpz` file will resume the project.

### Exercises

**Supersonic Flow Over a Cone**

Change the geometry from a wedge to a cone. What do you expect to change?

In the *Outline* window, click on *General* under *Problem Setup*. Under *2D Space* select *Axisymmetric*. We also need to change the boundary condition for the symmetry to an axis. Click on *Boundary Conditions* in the *Outline* window. In the *Boundary Conditions* window, under *Zone*, select *Symmetry*. Change the *Type* to *Axis*. Now, reinitialize the solution, then run it again for 100 iterations.

The result is displayed below. We did not change the mesh through adaption for this instead using the mesh generated in the tutorial. This needs be checked against the theoretical results for supersonic flow over a cone.

To look at the theory describing supersonic flow over a cone, see [NASA's website](https://www.nasa.gov).
Separated Shock

Next, we will alter the geometry to achieve a separated shock. Close FLUENT and open the Design Modeler. We want to increase the angle of the wedge above its critical angle. We will increase the angle to 35 degrees. Change the geometry's dimensions to match that of the diagram below.

![Diagram of separated shock](image)

Once the geometry has changed, close the design modeler. We will have to re-calculate the solution, but we will want to change some factors affecting the solution. Usually, when you make an upstream change in ANSYS, the program will update all of the downstream data. We want to break this connection, so right click

And select **Reset**. We will have to input the boundary conditions again, but that shouldn't take long – and will end up saving us time when we calculate the solution inside of the FLUENT environment.

Next, open up the mesher by double clicking

Update the mesh by clicking

Close the mesher, click , then once again double click

Re-enter all of the data from Step 5 (Physics Setup). This time, set the **Courant Number** to **1.0**. This will make the solution more stable, but it will solve more slowly. Run the solution again, this time with 5000 iterations.
Plot the contour plot of the mach number to see how the shock has changed.