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Problem Specification 

 

Consider air flowing at high-speed through a convergent-divergent nozzle having a 

circular cross-sectional area, A, that varies with axial distance from the throat, x, 

according to the formula  

A = 0.1 + x2; -0.5 < x < 0.5 

where A is in square meters and x is in meters. The stagnation pressure po at the inlet is 

101,325 Pa. The stagnation temperature To at the inlet is 300 K. The static pressure p 

at the exit is 3,738.9 Pa. We will calculate the Mach number, pressure and temperature 

distribution in the nozzle using FLUENT and compare the solution to quasi-1D nozzle 

flow results. The Reynolds number for this high-speed flow is large. So we expect 

viscous effects to be confined to a small region close to the wall. So it is reasonable to 

model the flow as inviscid. 
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Pre-Analysis & Start-Up 

Hand Calculations 

In quasi - one dimensional flow for this converging diverging nozzle, we expect 
that the Mach number at the inlet will be subsonic and accelerating until at the 
minimum nozzle area (the throat) the flow becomes sonic with M = 1. At that 
point, we expect that since the nozzle starts to diverge the flow will continue 
accelerating until at the exit, the flow continues as supersonic. We get to this 
result via the area velocity relation: 

𝑑𝐴

𝐴
= (𝑀2 − 1)

𝑑𝑉

𝑉
 

Open ANSYS Workbench 

We are ready to do a simulation in ANSYS Workbench! Open ANSYS 
Workbench by going to Start > ANSYS > Workbench. This will open the start up 
screen seen as seen below 

 

Setup Project 

To begin, we need to tell ANSYS what kind of simulation we are doing. If you 
look to the left of the start up window, you will see the Toolbox Window. Take a 
look through the different selections. We will be using FLUENT to complete the 
simulation. Load the Fluid Flow (FLUENT) box by dragging and dropping it into 
the Project Schematic. 
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Right click the top box of the project schematic  and go 
to Rename, and name the project “Compressible Flow in a Nozzle”. You are 
ready to create the geometry for the simulation.  

Step 1: Geometry 

We only need to model half of the nozzle cross-section because it can be 
solved using the axisymmetric solver in FLUENT. The 2D axisymmetric 
geometry has 4 edges; we will need to import a coordinate file to create the 
diverging-converging nozzle wall. The coordinate file can be found in the 
tutorial archive. 

Coordinates File 

You should see five columns of data in the coordinates file. 
The first column is the Group number . The coordinates data are assigned to 
groups to distinguish edges. 

The second column is the Group ID . Each set of coordinate needs to be 
assigned an ID so they can be imported in the correct order. 
The third column is the x coordinate . It varies from -0.5 to 0.5 , as shown in 
the problem statement. 

The fourth column is the y coordinate . The y coordinate (radial 
coordinate) can be written as the radius of the nozzle in terms of nozzle cross 
section area: 

A = pi*r^2. 
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for the given nozzle geometry, we get 

r(x) = [(0.1 + x2)/pi]0.5; -0.5 < x < 0.5 

The last column is the z coordinate . Although we are working with a 2D 
model, the tool we will use to import the coordinates requires coordinates in all 
three directions. We can conveniently set the z coordinates to 0 . The 
coordinates in the text file need to be grouped in a way that the end coordinate 
of a group must be the start coordinate of the next group. For instance, the end 
coordinate of group 1 is (0.5 0.333778669, 0) is the same as the start 
coordinate of group 2. 

Create the Geometry 

Watch the tutorial video. 

A summary of the video steps is shown below: 

1. Drag Fluid Flow (FLUENT) to the Project Schematic 
a. Rename it 2D Nozzle 

2. Right click on Geometry > Properties 
a. Analysis Type > 2D 

3. Right click on Geometry > New Design Modeler Geometry,  to open up 
Design Modeler 

4. Select Meters as Units 
5. Go to Top Menu, click on Concept > 3D curve 

a. For Coordinate File > Browse and select nozzle coordinates.txt 
6. Click on the Zoom to Fit icon 
7. Click on Concept > Surfaces (Edges) 

a. Click on all four edges 
8. Generate 

Note that while following the video above, you can select the 4 edges to create 
a surface in two ways: 

1. By holding down the Ctrl key and clicking on the 4 edges in turn. 
2. By "painting" over the 4 edges i.e. dragging the left mouse button 

over the four edges. This feature is called paint select. 

Suppress line bodies 

You need to suppress the line bodies before moving on, otherwise you might 
get an error later. Right click on each line body and select Suppress Body as 
shown below. Then, save your project before moving to the next step. 
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Since the nozzle has a circular cross-section, it's reasonable to assume that the flow is 

axisymmetric. So the geometry to be created is two-dimensional. 

Step 3 Mesh 

Watch the tutorial video. 

A summary of the video steps is shown below: 

1. Right click on Mesh > Insert > Face Meshing 
2. Click on face of the geometry > Apply 
3. Right click on Mesh > Insert > Sizing 
4. Click on Select Body icon > click on geometry > Apply 
5. Under Element Size enter 0.025 m 
6. Generate 

After creating the surface, name each of the edges of the surface. Do this by 
using the edge selection tool, right clicking on the line that you want to name, 
selecting 'Create a Named Selections' and typing in your desired name, then 
click the 'Generate' symbol to generate that named selection. You will want to 
name the pressure inlet, the outlet, the nozzle wall, and the axis. 
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Step 4: Set Up Problem in FLUENT 

Define Properties 

General 

Under the General box, select Density-Based. Under 2D Space, choose Axisymmetric.  

 

Click OK.  

Models > Viscous  

Select Inviscid under Model.  

 

Click OK.  
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Define > Models > Energy  

The energy equation needs to be turned on since this is a compressible flow where 

the energy equation is coupled to the continuity and momentum equations.  

Make sure there is a check box next to Energy Equation and click OK.  

 

Define > Materials  

Select air under Fluid materials. Under Properties, choose Ideal Gas next to Density. 

You should see the window expand. This means FLUENT uses the ideal gas equation 

of state to relate density to the static pressure and temperature.  

 

Click Change/Create. Close the window.  
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Define > Operating Conditions  

We'll work in terms of absolute rather than gauge pressures in this example. So set 

Operating Pressure in the Pressure box to 0.  

 

Click OK.  

It is important that you set the operating pressure correctly in compressible flow 

calculations since FLUENT uses it to compute absolute pressure to use in the ideal 

gas law.  

Define > Boundary Conditions  

Set boundary conditions for the following surfaces: centerline, inlet, outlet, wall.  

Select inlet under Zone and pick pressure-inlet under Type as its boundary condition. 

Click Set.... The Pressure Inlet window should come up.  
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Set the total (i.e. stagnation) pressure (noted as Gauge Total Pressure in FLUENT) 

and temperature at the inlet. For a subsonic inlet, Supersonic/Initial Gauge Pressure 

is the initial guess value for the static pressure. Enter 99348 for the Supersonic/Initial 

Gauge Pressure. After you have entered the values, click OK to close the window.  

Under the Thermal tab, the Total Temperature should be 300.  

 

Using the same steps as above, pick pressure-outlet as the boundary condition for the 

outlet surface. Then, when the Pressure Outlet window comes up, set the total 

pressure to 3738.9 as specified in the problem statement.  



10 

 

 

Click OK.  

Make sure that wall zone is set to wall type and the centerline zone is set to axis type.  

Set Reference Values 

Under Setup > Click Reference values > from the compute from drop down menu > 

select pressure-inlet  

These reference value numbers will be used in calculating non-dimensional number 

such as drag coefficient 

The gauge total pressure at the inlet boundary is the total (stagnation) 
pressure. This value is taken as is. The supersonic/initial gauge pressure is an 
initial guess for the static pressure at the inlet. This value will get updated if the 
flow at the inlet is subsonic. This value will not get updated if the inlet velocity 
is supersonic since disturbances cannot propagate upstream in this case. In 
our problem, the inlet velocity is going to be subsonic, so the static pressure at 
the inlet will get updated. You just need to make sure you provide a reasonable 
initial guess for the static pressure so that the iterations converge. This is 
illustrated in the figure below. 
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Keep in mind that all pressures you enter are gauge: Absolute pressure = 
Gauge pressure + Reference pressure. The reference pressure is set to zero 
under "Operating conditions" in the tutorial video. So, there is no difference 
between gauge and absolute pressures. This is a good idea for highly 
compressible flows where one gets significant variation in pressure across the 
domain. In contrast, for low speed flows, where absolute pressure variation 
might not be significant, giving a reasonable reference pressure will ensure 
that gauge pressure variations are still significant and minimize rounds-off 
errors (essentially you avoid having to take small differences of large 
numbers).  

Note: If using a different fluid than air, you must assign the material under the 
cell zone conditions. Do this by going to Cell Zone Conditions, clicking on 
'surface body', selecting the material name that you want, and click OK. 

 

Step 5: Numerical Solution 

Watch the tutorial video. 

A summary of the video steps is shown below: 

1. Under Solution Methods > Spatial Discretization 
a. Set Gradient to Least Squares Cell Based  
b. Set Flow to Second Order Upwing 

2. Under Solution > Monitors 
a. Residuals  

i. Set all Residual Convergence Criteria to 1e-6 
3. Under Solution > Solution Initialization 

a. Select Standard Initialization > Compute from Inlet 
4. Under Run Calculation  

a. Set Number of Iterations to 150  
b. Calculate 

  

What does the convergence plot look like?  

How many iterations does it take to converge?  

Save case and data after you have obtained a converged solution.  
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Step 6: Analyze Results 

Static Pressure Plot 

We are going to plot the velocity along the centerline and wall. We are going to use 

the Static Pressure.  

Plot > XY Plot  
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Click Plot.  

 

Mach Number Plot 

We are going to plot the velocity along the centerline. However, this time, we are 

going to use the dimensionless Mach quantity.  

Plot > XY Plot  

We are going plot the variation of the Mach number in the axial direction at the axis 

and wall. In addition, we will plot the corresponding variation from 1D theory. You 

can download the file here: mach_1D.xy.  

Do everything as we would do for plotting the centerline velocity. However, instead 

of selecting Axial Velocity as the Y Axis Function, select Mach Number.  

Also, since we are going to plot this number at both the wall and axis, select 

centerline and wall under Surfaces.  

Then, load the mach_1D.xy by clicking on Load File....  

 

http://courses.cit.cornell.edu/fluent/nozzle/mach_1D.xy
http://courses.cit.cornell.edu/fluent/nozzle/mach_1D.xy
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How does the FLUENT solution compare with the 1D solution?  

Is the comparison better at the wall or at the axis? Can you explain this?  

Save this plot as machplot.xy by checking Write to File and clicking Write....  

 

 

Velocity Vector Plot 

 

Under Results > Graphics > Select Vectors> Press Setup > Choose vectors of 

velocity> Color by Velocity, Mach Number 
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Pressure Contour Plot 

Sometimes, it is very useful to see how the pressure and temperature changes 

throughout the object. This can be done via contour plots. 

Under Results > Graphics > Select Contours> Press Setup > Choose Contours of 

Pressure> Static Pressure  

We want this at a fine enough granularity so that we can see the pressure changes 

clearly. Under Levels, change the default 20 to 40. This increases the number of lines 

in the contour plot so that we can get a more accurate result.  
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Click Display.  

 
(Click picture for large image)  
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Notice that the pressure on the fluid gets smaller as it flows to the right, as is 

consistent with fluid going through a nozzle.  

Total pressure Contour are displayed below 

 

Mach Number Contour Plot 
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Temperature Contour Plot 

Now we will plot the temperature contours and see how the temperature varies 

throughout the nozzle.  

Back in the Contours window, under Contours Of, select Temperature... and Static 

Temperature.  

Click Display.  

 

As we can see, the temperature decreases towards the right side of the nozzle, 

indicating a change of internal energy to kinetic energy as the fluid speeds up.  

 

Step 7: Refine Mesh 

Solve the nozzle flow for the same conditions as before and change the element size 

to 0.0125 m instead of 0.025 m. 

(a) Plot the variation of Mach number at the axis and the wall as a function of the 

axial distance x. Also, plot the corresponding results obtained on the first mesh and 

from the quasi-1D assumption. Recall that the quasi-1D result for the Mach number 

variation was given to you in the M_1D.xy file. Note all five curves should be plotted 

on the same graph so that you can compare them. You can make the plots in 
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FLUENT, MATLAB or EXCEL. 

(b) Plot the variation of static pressure at the axis and the wall as a function of the 

axial distance x. Also, plot the corresponding results obtained on the 50x20 grid used 

in class and from the quasi-1D assumption.  

 

(c) Plot the variation of static temperature at the axis and the wall as a function of the 

axial distance x. Also, plot the corresponding results obtained on the 50x20 grid used 

in class and from the quasi-1D assumption. Calculate the static temperature variation 

for the quasi-1D case. 

Comment very briefly on the grid dependence of your results and the comparison 

with the quasi-1D results.  

 

 

 

 


